[squeak-dev] The Inbox: Compiler-ct.459.mcz

Jakob Reschke jakres+squeak at gmail.com
Sun May 2 13:38:26 UTC 2021

I guess these names come from the ANSI standard, which defines
protocols "exceptionBuilder", "exceptionDescription",
"exceptionInstantiator", and "exceptionSelector" (with this camel case

Otherwise I see no problem in renaming them, since for now these are just words.

Am Sa., 1. Mai 2021 um 14:04 Uhr schrieb Christoph Thiede
<christoph.thiede at student.hpi.uni-potsdam.de>:
> By the way, I think we have a few category names in the image that are really
> unnecessarily complicated and could be renamed. For instance, on Exception,
> 'exceptionBuilder', 'exceptionDescription', and 'priv handling', and on its
> class side, 'exceptionInstantiator' and 'exceptionSelector'. These are
> counter examples of good category names in my opinion.
> Do you think it would be possible and worth renaming them? Or is this too
> much noise?
> Best,
> Christoph
> -----
> Carpe Squeak!
> --
> Sent from: http://forum.world.st/Squeak-Dev-f45488.html

More information about the Squeak-dev mailing list