[squeak-dev] CompiledMethod >> #=

Chris Muller asqueaker at gmail.com
Tue Jan 11 23:01:05 UTC 2022

> Would renaming that to something like #semanticallySimilarTo: make it
> clearer?


Christoph's find is surprising.  It seems impossible to consider two
CompiledMethods with different names "equal" in terms of the universal
expectations of #=.

#= should be as strict as necessary, while use-case-specific tests
should use use-case-specific names.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20220111/2a8e862a/attachment.html>

More information about the Squeak-dev mailing list