[Vm-dev] Crash on start-up.

Michael van der Gulik mikevdg at gmail.com
Wed Mar 18 07:49:02 UTC 2009

Hi VM guys.

Does anybody have any insights into the following?:

I get the following crash. I've tried this on a Windows VM of unknown
version and a 3.9-alpha Linux VM with the same result:

Segmentation fault

-1528952856 [] in Semaphore>critical:
-1528953680 BlockContext>ensure:
-1528953772 Semaphore>critical:
-1528953864 >clearExternalObjects
-1528953956 SystemDictionary>clearExternalObjects
-1529116848 SmalltalkImage>snapshot:andQuit:embedded:
-1529116940 SmalltalkImage>snapshot:andQuit:
-1529117032 TheWorldMenu>saveAndQuit
-1529117216 TheWorldMenu>doMenuItem:with:
-1529117308 [] in MenuItemMorph>invokeWithEvent:
-1529117400 BlockContext>ensure:
-1529117492 Cursor>showWhile:
-1529117712 MenuItemMorph>invokeWithEvent:
-1529117804 MenuItemMorph>mouseUp:
-1529117896 MenuItemMorph>handleMouseUp:
-1529118028 MouseButtonEvent>sentTo:
-1529118120 Morph>handleEvent:
-1529118212 MorphicEventDispatcher>dispatchDefault:with:
-1529118304 MorphicEventDispatcher>dispatchEvent:with:
-1529118396 Morph>processEvent:using:
-1529118488 MorphicEventDispatcher>dispatchDefault:with:
-1529118596 MorphicEventDispatcher>dispatchEvent:with:
-1529118728 Morph>processEvent:using:
-1529118820 Morph>processEvent:
-1529118912 MenuMorph>handleFocusEvent:
-1529119188 [] in HandMorph>sendFocusEvent:to:clear:
-1529119096 [] in PasteUpMorph>becomeActiveDuring:
-1529119280 BlockContext>on:do:
-1529119372 PasteUpMorph>becomeActiveDuring:
-1529119556 HandMorph>sendFocusEvent:to:clear:
-1529119648 HandMorph>sendEvent:focus:clear:
-1529119740 HandMorph>sendMouseEvent:
-1529119884 HandMorph>handleEvent:
-1529120168 HandMorph>processEvents
-1529120076 [] in WorldState>doOneCycleNowFor:
-1529120260 SequenceableCollection>do:
-1529120352 WorldState>handsDo:
-1529120444 WorldState>doOneCycleNowFor:
-1529120536 WorldState>doOneCycleFor:
-1529120628 PasteUpMorph>doOneCycle
-1529214452 [] in >spawnNewProcess
-1529214268 [] in BlockContext>newProcess
Segmentation fault (core dumped)

This happens on start-up. None of the VM flags I tried make a difference.

I suspect this may have caused it:

!EventSensor methodsFor: 'as yet unclassified' stamp: 'mvdg 3/17/2009 21:54'
prior: 36505616!
  panicButtonPressed := false.

  Smalltalk.Sensor shutDown.
  inputSemaphore := Semaphore new.
  Smalltalk.ExternalSemaphoreTable registerExternalObject: inputSemaphore.
  self primSetInputSemaphore: inputSemaphore.

  self enterEventLoop.
 ] ensure: [
  Smalltalk.Sensor startUp.
  Smalltalk.Display restore.
 ].! !

This code worked fine until I saved, quit and tried to reopen the image.

Note that this class is actually defined in my namespaces implementation -
it does not exist in the SystemDictionary and has it's environment set to an
instance of Namespace. It is my own implementation of EventSensor and I've
added the primitive methods to it. I'm not sure if any of this matters.

I'm going to put this image aside rather than try to fix the above and make
a new image so I can continue my work. This problem will continue to exist,
however, so if I have any breakthroughs as to what is happening, I'll post a

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20090318/611ee170/attachment.htm

More information about the Vm-dev mailing list