[Vm-dev] [OpenSmalltalk/opensmalltalk-vm] 931559: Replace another
(UINT) cast by (usqIntptr_t) for L...
nicolas.cellier.aka.nice at gmail.com
Fri Jul 8 16:55:44 UTC 2016
2016-07-08 16:27 GMT+02:00 Ben Coman <btc at openinworld.com>:
> On Fri, Jul 8, 2016 at 5:44 PM, GitHub <noreply at github.com> wrote:
> > Branch: refs/heads/Cog
> > Home: https://github.com/OpenSmalltalk/opensmalltalk-vm
> > Commit: 931559445c72d9a53541289330ddb5157c94daf5
> > Author: Nicolas Cellier <nicolas.cellier at sirehna.com>
> > Date: 2016-07-08 (Fri, 08 Jul 2016)
> > Changed paths:
> > M platforms/win32/vm/sqWin32Main.c
> > Log Message:
> > -----------
> > Replace another (UINT) cast by (usqIntptr_t) for LLP64 compatibility
> Just curious, why not put the "sq" at the front?
> It would seem to better categorise application specific types.
> cheers -ben
I'm following existing pattern: sqInt usqInt sqLong usqLong ...
It's better both for uniformity and also because the pattern is exploited
by special handling in CodeGenerator
(int types beginning with $u...)
> > (UINT) would not work on LP64 anyway, it would truncate the pointer.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Vm-dev