[Seaside] Gemstone / Magritte

Todd Blanchard tblanchard at mac.com
Tue Aug 7 20:23:43 UTC 2007

You might consider 'magritteDescription' since that's what you're  
essentially getting when you call it.
Says what it is.  Does what it says.

On Aug 7, 2007, at 11:49 AM, Lukas Renggli wrote:

>> It should be fixed in Gemstone as well as
>> Magritte, though I've long since worked my way around the latter  
>> because I
>> don't see it happening.
> Did you ever think that a selector name choice might turn into a
> nightmare 4 years later? Magritte did not start as a framework, but
> evolved from a couple of helper classes in SmallWiki. It is clear that
> any selector name potentially leads to conflicts. I agree that
> #descriptor would have been a slightly better, but the fact that I
> know a couple of packages that implement #descriptor is not really
> motivating me to make that change.
>> A good reason to fix it is simply that it continually comes up as  
>> an issue
>> for any English speaking user, #description is far to common and  
>> far to
>> general a selector for domain objects to ever put it on as a meta  
>> selector
>> on object.
> I doubt that this has anything to do with the language the users are
> speaking. Most people write their application in english anyway.
> Lukas
> -- 
> Lukas Renggli
> http://www.lukas-renggli.ch
> _______________________________________________
> Seaside mailing list
> Seaside at lists.squeakfoundation.org
> http://lists.squeakfoundation.org/cgi-bin/mailman/listinfo/seaside

More information about the Seaside mailing list