[Squeakland] cannot publish a file anymore

Scott Wallace scott.wallace at squeakland.org
Wed Dec 15 21:41:01 PST 2004

Hi again, Arvind.

Sorry it's taken so long to track this down, but I think I now 
(finally) have a good fix for this student's damaged project and 
others like it.

Please try out the attached, which (if it passes the smoke test) will 
find its way into the squeakland update stream before long.

To test it, follow the instructions as for the previous fileout I 
sent out on Monday, which should be discarded.

After installing the new fileout, your student will find that she can 
load in her old project, request "attempt misc. repairs" from the 
"authoring tools" menu, then republish her project, and the resulting 
new .pr file should be fine to load into any Squeakland image whether 
it yet has this fix in it or not.

Please let me know how this flies...


  -- Scott

At 1:55 AM -0800 12/14/04, Scott Wallace wrote:
>Hi, Arvin,
>The fileout I sent earlier had a bug, which accounts for the error 
>you ran into after loading it.
>I've now got a fixed version of my fileout.  But there's still 
>something wacky, in that when you republish a project that has the 
>bogus scripts stripped, they reappear.  Tracking this down has 
>eluded me tonight, but I'll attack it again tomorrow.
>Meantime, the seemingly-somewhat-improved state of that project 
>(after republishing it after loading my early, buggy fileout and 
>then doing "attempt misc repairs") is actually still not good 
>enough, in that the project-file it creates will still require an 
>image that has my fixes in it to be usable.
>So please hold off on this for another little while and hopefully 
>I'll be able to sort this out soon.
>  -- Scott
>At 10:18 PM -0500 12/13/04, Arvind S. Grover wrote:
>>Scott, I really appreciate the help. I tried the patch you sent me, and
>>when I tried misc repairs, it crashed. But, then when I tried
>>publishing, it took a while, and told me:
>>"Some block(s) which reference instance variables are included in this
>>segment. These may fail when the segment is loaded if the class has been
>>reshaped. What would you like to do?"
>>I could choose keep going or stop and take a look. When I choose keep
>>going, it seems to publish normally, but always asks whenever I want to
>>publish. I am not sure exactly what I am looking for when I choose take
>>a look.
>>If this is the best we can get this project, is will be just fine. It
>>have anything to add, please let me know. I attached the original .pr
>>file. Again, I can't thank you enough for the help.
>>-----Original Message-----
>>From: Scott Wallace [mailto:scott.wallace at squeakland.org]
>>Sent: Monday, December 13, 2004 9:08 PM
>>To: Arvind S. Grover
>>Cc: squeakland at squeakland.org; Michael Rueger; Kim.Rose at squeakland.org
>>Subject: Re: FW: [Squeakland] cannot publish a file anymore
>>Hi, Arvind,
>>Apparently this project had gotten into an inconsistent state
>>sometime before the publishing was attempted.
>>Since you mentioned that you've tried to publish the same project on
>>more than one computer, and encountered the same problem, I wonder
>>*what* you copied from computer to computer for the successive
>>trials.  Was it an earlier version of the .pr project file that *had*
>>been successfully published?  Or did you copy over the
>>squeakPlugIn.image from one machine to the next?
>>If you still to have a saved copy of the image in which this error
>>occurred, please try this:
>>(1)  Place the attached file into the "My Squeak" folder on the
>>computer that has the Squeak image with the offending project.
>>(2)  Start up the image that has the error.
>>(3)  "Install" the attached file from a filelist (hit shift-esc to
>>get the world menu, choose "open", then "file-list"; select the file
>>and then hit the "install" button.)
>>(4)  Choose "attempt misc repairs" from the "authoring tools" menu
>>(hit shift-esc to get the world menu, then choose "authoring tools",
>>then "attempt misc repairs.")
>>(5)  Now try to publish the project again.
>>*** Alternatively, if you could by any chance make that image
>>available to us on some ftp site, we could download it and take a
>>direct look.
>>If the offending image is no longer available for trying this out, of
>>course, this won't do your student much good -- sorry.  However,
>>probably the attached code, or something derived from it, will appear
>>in a forthcoming Squeakland update to help work around similar error
>>conditions in the future.
>>   -- Scott
>>PS:  If you have no image but do have a previously-successfully-saved
>>.pr file for the project, please email *that* to me privately, if you
>>At 1:04 PM -0500 12/13/04, Arvind S. Grover wrote:
>>  >Since Michael has been able to correct the attachments issue, I am
>>>resending my log attachment. Any help would be appreciated.
>>>-----Original Message-----
>>>From: squeakland-bounces at squeakland.org
>>>[mailto:squeakland-bounces at squeakland.org] On Behalf Of Arvind S.
>>>Sent: Monday, December 13, 2004 11:25 AM
>>>To: squeakland at squeakland.org
>>>Subject: [Squeakland] cannot publish a file anymore
>>>...I have a student who has a 1 megabyte file, and each time she tried to
>>>publish, it hangs while publishing. I have attached the log. I have
>>>tried on different computers with no luck.
>>>Any ideas? Thanks again,
-------------- next part --------------
Skipped content of type multipart/appledouble

More information about the Squeakland mailing list